PplWare Mobile

Dicas do Microsoft Excel é ao Domingo…no Pplware – 23


Pedro Pinto

Pedro Pinto é Administrador do site. É licenciado em Engenharia Informática pelo Instituto Politécnico da Guarda (IPG) e obteve o grau de Mestre em Computação Móvel pela mesma Instituição. É administrador de sistemas no Centro de Informática do IPG, docente na área da tecnologia e responsável pela Academia Cisco do IPG.

Destaques PPLWARE

  1. Blackbit says:

    Muito bom, obrigado por nos fazer descobrir essa função!

  2. José Augusto says:

    Bom Domingo

    Espero ver mais comentários que na semana anterior pois este artigo está Muito Bom.
    Apenas mais umas dicas que ajudam a compreender o que se passa no interior SOMARRODUTO quando usamos (A2:A13=A15).

    Iremos usar uma fórmula matricial que obriga a validar com CTRL+SHIFT+ENTER em vez de apenas ENTER.

    Para isso seleccione-se o intervalo F2:F15 e mantendo a seleccão escreva-se na barra de fórmulas a fórmula
    =(A2:A13=A15)
    terminando-a com CTRL+SHIFT+ENTER

    Os valores de F2 a F6 estarão preenchidos com FALSO e os restantes com VERDADERO (a fórmula ficará entre chavetas).

    Seleccionem-ne novamente as células F2:F15 e, na barra de fórmulas, altere-se a fórmula para
    =(A2:A13=A15)+0
    terminando com CTRL+SHIFT+ENTER

    Os valores FALSO são transformados em zero e os verdadeiros em 1.
    Para vermos 1 nas linhas das quantidades compradas pelo João Silva em Janeiro podemos alterrar a fórmula anterior, procedendo de maneira identica à já usada,
    =(A2:A13=A15)*(B2:B13=A16)+0
    Aqui, a multiplicação funciona como o operador lógico E. Para usarmos OU em vez de E usamos a soma em vez da multiplicação.

    A dica final:
    Seleccione a célula C15 e escreva a seguinte fórmula:
    =SOMA((A2:A13=A15)*(B2:B13=A16)*(D2:D13))
    e termine com CTRL+SHIFT+ENTER
    Surpresa? ou talvez não.

    Bom resto de dia

    • Pedro Pinto says:

      Sem duvida, é importante que os nossos leitores contribuam também com as suas dias e que participem nos comentários. Só assim poderemos saber quais os temos que gostariam de ver aqui abordados.

  3. M.Manuelito says:

    Todos os domingos aprendo um pouco mais de excel….excelente série de artigos.

  4. Paulo Correia says:

    A fórmula somaproduto têm um pequeno problema que de vez em quando pode dar chatices.

    Quando ela multiplica os valores das matrizes, não faz arredondamentos parciais, pelo que o valor total pode (e geralmente é) um pouco diferente do valores que obteríamos caso se fizessem os cálculos da maneira tradicional, isto é, com fórmulas arredondando linha a linha e um somatório no final.

    Geralmente são valores pequenos, mas podemos perder imenso tempo até perceber porquê

    • José Augusto says:

      Pode usar-se

      =SOMA(ARRED(H15:H22*J15:J22;0)) (CTRL+SHIFT+ENTER)

      em vez de ARRED(SOMARPRODUTO(H15:H22;J15:J22);0) ENTER.

      A fórmula matricial arredonda linha a linha ARRED(H15*J15;0), ARRED(H16*J16;0)… e só depois soma.

      Espero que ajude.

      • Paulo Correia says:

        Não conhecia, obrigado

        Embora não goste das formulas matriciais excepto para uso próprio. São demasiado perigosas. Basta editarem e deixam de funcionar.

        Como distribuo muitos ficheiros em Excel, não arrisco

  5. Bom dia,

    Gostaria de saber se tem algum jeito de eliminar o limite de 218 caracteres para o nome do arquivo no Excel?

    Eu preciso guardar os meus ficheiros Excel no disco D, dentro de uma série de pastas que dividem o curso que frequento por UFCDs.

    Será que me podem ajudar? Já percorri tudo o que é site e até agora a única solução encontrada é guardar no Ambiente de Trabalho e copiar à posterior para a pasta desejada.
    Depois do ficheiro estar lá ele permite guardar as alterações ao ficheiro. Só não permite é usar a opção guardar como, ou seja, não permite inicialmente criar o ficheiro naquela localização.

Deixe uma resposta

O seu endereço de email não será publicado.

You may use these HTML tags and attributes: <a href="" title="" rel=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

*

Aviso: Todo e qualquer texto publicado na internet através deste sistema não reflete, necessariamente, a opinião deste site ou do(s) seu(s) autor(es). Os comentários publicados através deste sistema são de exclusiva e integral responsabilidade e autoria dos leitores que dele fizerem uso. A administração deste site reserva-se, desde já, no direito de excluir comentários e textos que julgar ofensivos, difamatórios, caluniosos, preconceituosos ou de alguma forma prejudiciais a terceiros. Textos de caráter promocional ou inseridos no sistema sem a devida identificação do seu autor (nome completo e endereço válido de email) também poderão ser excluídos.