PplWare Mobile

Dicas do Microsoft Excel é ao Domingo…no Pplware – 10


Pedro Pinto

Pedro Pinto é Administrador do site. É licenciado em Engenharia Informática pelo Instituto Politécnico da Guarda (IPG) e obteve o grau de Mestre em Computação Móvel pela mesma Instituição. É administrador de sistemas no Centro de Informática do IPG, docente na área da tecnologia e responsável pela Academia Cisco do IPG.

Destaques PPLWARE

  1. Eduardo says:

    A função Se() é mais poderosa do que mera validação. Permite a construção de funções bastante complexas dependentes de múltiplos dados.

  2. Paulo Bastos says:

    Já agora para quando Dicas para Photoshop? fica a sugestão.

  3. Orite says:

    Na função “E” parece-me existir um lapso no exemplo, pois escreveram com a função “SE”: =SE(B2>=9,5;C2>=9,5;)
    Cumptos.

  4. rom_c says:

    Boas.
    Considerando A1 como o local da nota final:

    =SE(TIPO(A1)=1;SE(A1=””;””;SE(A1<9;"REPROVADO";SE(A1<=10,5;"EM ANÁLISE";"APROVADO")));"ERRO")

  5. Boas!

    Sei que é um pouco fora do contexto mas pode ser que alguém me consiga ajudar nisto…

    Há alguma forma de procurar pelo “valor mais recente”?
    Por exemplo, tenho uma coluna de A1 e por aí abaixo, na qual vou introduzindo valores novos, mas preciso que numa determinada célula me apreça somente o valor mais recente que tenha sido introduzido nessa coluna de A1 …

    Bom Domingo!

  6. Rui João says:

    Boas,

    Eu tenho duas colunas, uma com as Siglas, outro com os Nomes, e estou a utilizar a função Procv.

    Ora, gostava de saber, como poderia fazer com que as duas se unissem, género:

    Se utilizar RJ ou 12, ele escreve o meu nome, Rui João..

    Se não tiver sido bem explicativo, digam, para ver se me explico melhor.

    Bons artigos para nos ensinar Excel 😉

  7. Uso a função SE para criar boletim escolar.

  8. iSma_ says:

    Excelentes dicas.

  9. paulo g. says:

    Este é mais um excelente tutorial para LibreOffice Calc, pois usa exactamente as mesmas funções. Colocarei o vídeo baseado neste tutorial assim que poder.

  10. João Ferreira says:

    colA=nome | colB=teste1 | colC=teste2 | colC=teste3 | colD=SITUAÇÃO

    Colocar a seguinte fórmula na situação actual – coluna D (ou aprovado, ou em análise, ou aprovado)

    =+SE(MÉDIA(B7:D7)9.5;(MÉDIA(B7:D7)10.5;”aprovado”;0)))))

  11. João Ferreira says:

    peço desculpa, o teste3 é na coluna D e a situação final na coluna E… o restante mantém-se

  12. João Ferreira says:

    =+SE(MÉDIA(B7:D7)9.5;(MÉDIA(B7:D7)10.5;”aprovado”;0)))))

  13. João Ferreira says:

    o “+se” é irrelevante… desde que tenha o =se não precisa do “+”. NOTA: a formula não está a aparecer toda!

  14. Rui João says:

    Alguém me ajuda a escrever uma função com 2 Procv?

    Pretendo que usando um número, ou um abreviatura, apresente o mesmo resultado.

    Ex.
    Se utilizar RJ ou 12, ele escreve o meu nome, Rui João..

    Obrigado desde já

    • José Augusto says:

      Se o Procv não for obrigatório e usa o Excel 2007 ou 2010 a solução é …
      Considere:
      [B2:B10] as abreviaturas
      [C2:C10] os códigos numéricos (ou outros)
      [D2:D10] os nomes completos
      F2 é a célula que tem o valor a procurar (RJ ou 12)

      =SE(SE.ERRO(CORRESP(F2;$B$2:$B$10;0);0)+SE.ERRO(CORRESP(F2;$C$2:$C$10;0);0)>0;ÍNDICE($D$2:$D$10;SE.ERRO(CORRESP(F2;$B$2:$B$10;
      0);0)+SE.ERRO(CORRESP(F2;$C$2:$C$10;0);0);0);”Erro”)
      ou, na versão inglesa

      =IF(IFERROR(MATCH(F2,$B$2:$B$10,0),0)+IFERROR(MATCH(F2,$C$2:$C$10,0),0)>0,INDEX($D$2:$D$10,IFERROR(MATCH(F2,$B$2:$B$10,0),0)+IFERROR(MATCH(F2,$C$2:$C$10,0),0),0),”Erro”)

      A fórmula dá “Erro” caso o valor ou a abreviatura a pçrocurar não exista na tabela [B2:C10].

      • Rui João says:

        +1 vez agradeço a gentileza de me ter ajudado.

        O problema é que o Excel queixa-se que A função que colocou tem excesso de argumentos.

        Diz também para colocar um sinal de igual no inicio da função.. coisa parva.. mas que dá erro, dá 🙁

        Obrigado pela sua paciência

  15. Rui João says:

    José Augusto, antes de mais Obrigado pelo código, e pela ajuda, irei testar.

    Obrigado +1 vez 😀

    Tudo de bom 😉

  16. Filipe says:

    A ver se eu me consigo explicar bem….
    Haverá alguma forma ou fórmula no Excel para numa tabela de várias linhas e várias colunas, por exemplo, e quando eu mexo numa célula saber qual a linha em que estou a mexer? Ou seja como se eu sublinhasse essa linha toda, quando mexo numa célula gostava que me aparecesse a linha toda seccionada para eu saber que linha estou a mexer!
    Se alguém souber alguma forma agradecia.
    Obrigado

  17. Pedro Meireles says:

    Boas.

    tenho uma duvida ja ha algum tempo em relação a função SE

    será possivel com base num teste lógico alterar a formatação da célula
    por exemplo:

    celula b1 = 20.000 eu quero que na célula b2 me apareça a vermelho quanro o valor de b1 é menor que 50.000, é possivel

    Obrigado.

  18. Samuel Afonso Pedro says:

    Pretendo Criar uma planilha em excel de minipauta com (5) cinco colunas, Nomeadamente nome, Mac, exame, média e nota final.
    Até aqui sei, oque me pretendo é que se a média for inferior a 10 vem reprova e se o exame for inferior a 10 vem igualmente reprovado. Por favor me ajudem

  19. Felipe Ferreira says:

    Olá, Pessoal!

    Venho parabenizar o ADMINISTRADOR deste site. Eu sou apaixonado por formulas em Excel, gosto demais!
    Faço algumas planilhas para uso pessoal e, sempre procuro ir melhorando minhas planilhas com FORMULAS INCRÍVEIS DO EXCEL.
    Abraço!

Deixe uma resposta

O seu endereço de email não será publicado.

You may use these HTML tags and attributes: <a href="" title="" rel=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

*

Aviso: Todo e qualquer texto publicado na internet através deste sistema não reflete, necessariamente, a opinião deste site ou do(s) seu(s) autor(es). Os comentários publicados através deste sistema são de exclusiva e integral responsabilidade e autoria dos leitores que dele fizerem uso. A administração deste site reserva-se, desde já, no direito de excluir comentários e textos que julgar ofensivos, difamatórios, caluniosos, preconceituosos ou de alguma forma prejudiciais a terceiros. Textos de caráter promocional ou inseridos no sistema sem a devida identificação do seu autor (nome completo e endereço válido de email) também poderão ser excluídos.