PplWare Mobile

Dicas do Microsoft Excel é ao Domingo…no Pplware – 4


Pedro Pinto

Pedro Pinto é Administrador do site. É licenciado em Engenharia Informática pelo Instituto Politécnico da Guarda (IPG) e obteve o grau de Mestre em Computação Móvel pela mesma Instituição. É administrador de sistemas no Centro de Informática do IPG, docente na área da tecnologia e responsável pela Academia Cisco do IPG.

Destaques PPLWARE

  1. MGOMES says:

    O tipo de dicas apresentados são demasiado obvias.
    em meu entender tendo em conta os utilizadores da vossa pagina deveria existir maior complexidade nas dicas .
    Pois colocar as que colocam é o mesmo de não colocar nada.

    • Pedro Pinto says:

      Caro MGOMES
      Depois de se saber fazer as coisas tudo é ÓBVIO e fácil!
      Começamos do inicio e vamos aumentando a complexidade.

      “Pois colocar as que colocam é o mesmo de não colocar nada” …Se já és expert (traduzido para PT “chico esperto”) então esta rubrica não é para ti. Aproveita e responde ao desafio.

    • Luiz says:

      @MGOMES você foi muito desrespeitoso.
      Se para você as dicas representam nada, respeito os outros que pensam diferente de você.
      E se és tão SÁBIO como pretendes demonstrar, por que não respondes ao desafio?
      Fores muito infeliz em teu comentário…

    • ITWare2008 says:

      Só agora encontrei esta rubrica, e creio ter algumas dicas interessantes para partilhar com todos. Quanto ao MGomes à dicas bem simples que deixam “xico-espertos” espantados. Vai um teste?

  2. Fernando Girão says:

    Relativamente ao desafio, creio que uma maneira poderia passar por ordenar os números e depois utilizar ou a formular exacto ou o se para comparar o número com o anterior e posterior. Depois aplicar-se-ia uma formatação condicional às linhas, de forma a realçar os valores devolvidos pelas formulas que mostrassem onde existissem repetições.

  3. Miguel Goyanes says:

    Formatação Condicional
    Nova Regra
    Formatar apenas valores exclusivos ou duplicados
    Formatar tudo -> Duplicados
    Alterar o preenchimento para a cor à escolha

    P.S. – Já nem me lembrava que isto dava para fazer de uma forma tão simples

    • Fernando Girão says:

      uiii… é mesmo muito fácil… só de pensar o trabalhão que me daria através das fórmulas 🙁

      • Miguel Goyanes says:

        Com as fórmulas tb dá ma acho que assim é mais fácil. Só me esqueci de mencionar que é precisão seleccionar as células que queremos modificar e que no mesmo sítio dá para formatar os valores exclusivos

  4. José Augusto says:

    Em resposta ao desafio.
    Assuma-se que o intervalo de células com valores é [B2:F10].
    Usa-se a formatação condicional, com a regra que utiliza a seguinte fórmula:

    =CONTAR.SE($B$2:$F$10;B2)>1

    e formata-se de acordo com a característica que se queira (Negrito, cor….)

    Querendo apenas realçar valores numéricos a formula deveria ser alterada para

    =E(CONTAR.SE($B$2:$F$10;B2)>1;É.NÚM(B2))

  5. Bovidino says:

    Poderiam fazer semelhante ajuda com o Calc do LibreOffice.
    Este é que uso mais.

    • José Augusto says:

      Para o LibreOffice ou Excel 2003
      Formatar
      Formatação condicional
      Condição 1
      (em vez de valor) Fórmula é
      Use a fórmula =CONTAR.SE($B$2:$F$10;B2)>1
      ou a fórmula =E(CONTAR.SE($B$2:$F$10;B2)>1;É.NÚM(B2))
      Aplique um novo estilo à célula.
      Atenção: O intervalo considerado [B2:F10] deve estar seleccionado quando invocamos a formatação condicional.

    • paulo g. says:

      E faz muito bem. Pagar ou ter o trabalho de piratear? É preferível “perder” tempo a aprender a ferramenta (neste caso o Calc) como deve ser. Vá lendo estas dicas que eu colocarei em vídeo para LivreOffice Calc, assim o Pedro me vá deixando e eu continue a ter tempo.

  6. João Pinto says:

    Como foi dito pelo Pedro, se tiverem alguma dúvida ou problema a resolver em Excel, podem colocar aqui que os leitores tentarão ajudar a resolver. Se tiverem alguma sugestão de algum tema que gostariam de ver abordado aqui, podem igualmente sugerir.
    Se acham que estes artigos são muito “básicos”, têm que continuar a seguir este site todas as semanas pois começou-se pelo principio e no futuro irão ser abordados temas mais avançados.

    Um abraço a todos os restantes leitores.

    João Pinto

  7. paulo g. says:

    Aqui vai o vídeo.
    http://youtu.be/3of8bRxjSds
    Introduzi mais umas coisitas pelo que o vídeo ficou um pouco longo. Falta é áudio para explicar, mais em pormenor algumas coisas.

    Objectivos:
    – Formatar contornos de células
    – Funções estatísticas: soma, média, mínimo e máximo
    – Referências entre células de folhas diferentes
    – Alterar nome da folha de cálculo
    – Criar novas folhas de cálculo
    – Cópias de dados entre folhas de cálculo
    – Formatação condicional

    • Miguel Goyanes says:

      Sugestão.

      Porque não, passado por exemplo um ou dois dias, existir o mesmo artigo que foi feito em Excel mas feito no Calc?

      Abordariam exactamente o mesmo tema e assim um ia acompanhando o outro.

      • paulo g. says:

        Nestes exercícios as diferenças são tão poucas entre um e outro programa, que acho que não vale a pena. Desta forma as pessoas vêem o LibreOffice Calc com menos preconceitos. No caso da formatação condicional realmente o Excel deu um salto, e espero que o LibreOffice o dê na versão 3.5 que está quase a sair.

    • Bovidino says:

      Gostei do vídeo. Muito bom. Boa ajuda.

  8. Chirucca says:

    Precisava de uma ajuda em Excel. Tenho uma lista de 1 a 25.000 e precisava de dividir essa lista em duas listas. Um com todos os números da lista de 1 25.000 que contenham o algarismo 8, e a outra lista com os restantes números que não contenham o algarismo 8.

    • João Pinto says:

      Se os teus números estão na coluna A, uma maneira é usares uma fórmula do género na coluna B:

      =SE(É.ERROS(PROCURAR(“8″,A2)),””,”tem 8″)

      Depois basta ir ao separador Dados e clicar em Filtrar. Basta depois filtrares na coluna B pelos que “tem 8” e copiar os dados para uma nova lista. Depois filtras pelos “Em branco” e copias para outra lista.

      João Pinto

    • paulo g. says:

      Podes usar o filtro automático e escolher o 8 numa das situações.
      Na outra vais à opção do filtro e escolhes diferente de 8. Sem fórmulas e sem complicação, pelo menos em LibreOffice Calc…

  9. Chirucca says:

    Nesta lista que eu consegui criar com a ajuda do João Pinto e do paulo g., é possível ainda separar na lista dos números com o algarismo 8 todos os n.ºs com inicio e/ou terminação com o algarismo 8?

    • Miguel Goyanes says:

      Se entendi bem precisas apenas de todos os valores que contenham o número 8 mas que não iniciem nem terminem com oito. Correcto?

      Se assim for, imaginemos que tens todos os teus dados na coluna A.

      Na coluna B preenche a célula B1 com =TEXTO(A1;0) e depois faz a série até à ultima linha.

      Na coluna C coloca a célula C1 com =SE(CONTAR.SE(B1;”?8?”)>0;1;0) que vai colocar 1 em todos os números que apenas têm oito nas posições intermédias.

      Depois é só filtar

      • Chirucca says:

        Olá Miguel. O que eu pretendia era precisamente os números de 1 a 25.000 com o algarismo 8 no inicio e/ou fim. Já consegui resolver este problema com a ajuda do José Augusto.

        De qualquer maneira muito obrigado pela colaboração, pois a tua ajuda/formula vou guardar a referência para futuros problemas semelhantes a este.

  10. José Augusto says:

    Pode usar-se a seguinte fórmula na coluna C assumindo os dados da coluna A (ou os da coluna B):

    =OU(INT(A2/10^(INT(LOG(A2;10))))=8;RESTO(A2;10)=8)

    que dará resultado verdadeiro para o caso de A2=897 ou A2=798 e falso para A2=7889.

  11. Simão says:

    Vi algumas das suas dicas e há uma dúvida que persiste.
    Eu ando a tentar fazer uma soma condicional de várias células em páginas diferentes, e obtenho sempre o erro “#valor”.

    O que eu escrevi foi:
    =SOMA.SE(’29:31′!N10;”<0")

    E também experimentei:
    =SOMA.SE.S('29:31'!N9;'29:31'!N9;"<0")
    Obtendo o mesmo erro

    Todas as células neste intervalo são números.

    O que é que eu estou a fazer de errado?

    • José Augusto says:

      Caro Simão

      As funções SOMA.SE e SOMA.SE.S ou a junção das funções SOMA e SE não resolvem o problema do grupo de folhas ’29:31′. Uma hipótese de solução será usar a função SOMA.SE em cada uma das folhas e usar a função SOMA daqueles resultados no grupo de folhas.

      Espero ter ajudado.

  12. Filipe says:

    A ver se eu me consigo explicar bem….
    Haverá alguma forma ou fórmula no Excel para numa tabela de várias linhas e várias colunas, por exemplo, e quando eu mexo numa célula saber qual a linha em que estou a mexer? Ou seja como se eu sublinhasse essa linha toda, quando mexo numa célula gostava que me aparecesse a linha toda seccionada para eu saber que linha estou a mexer!
    Se alguém souber alguma forma agradecia.
    Obrigado

  13. Mário Silva says:

    Olá,

    Gostava de saber se é possível fazer uma coisa.. Por exemplo, tenho dados de consumos de energia de 15 em 15 minutos de 1 ano numa coluna.. e quero ter os dados horários através da média de 4 fracções de 15 minutos (e ter 1/4 dos dados). No entanto não consigo fazer “saltar” as médias de 4 em 4 células.. fico sempre com o valor acumulado que não é o que me interessa

    É portanto possível que, de alguma forma, consiga fazer isto? Por exemplo, se tiver os dados na coluna A e as médias na coluna B, na célula B1 vou ter “Média(A1:A4)” e na B2 vou ter “Média(A2:A5)” enquanto o que quero é “Média(A5:A8)”.. Não é possível que o Excel me deixe fazer algo como definir na formula do género “Média(A2+3:A4+3)” e depois ser ser arrastar?

    Obrigado pela atenção

    • José Augusto says:

      Caro Mário Silva
      Para resolver o problema use a seguinte fórmula:
      =MÉDIA(DESLOCAMENTO(A$1:A$4;4*(LIN(A1)-1);0))
      A função DESLOCAMENTO encarrega-se de deslocar o intervalo A$1:A$4 para A$5:A$8, …
      Cumprimentos

  14. José Augusto says:

    Caro Mário Silva

    Para resolver o problema use a seguinte fórmula:

    =MÉDIA(DESLOCAMENTO(A$1:A$4;4*(LIN(A1)-1);0))

    A função DESLOCAMENTO encarrega-se de deslocar o intervalo A$1:A$4 para A$5:A$8, …

    Cumprimentos

  15. Ângelo Campos says:

    Precisava de uma ajuda se possível.
    Tenho uma tabela de nomes em que cada linha corresponde a uma folha:
    Pretendia criar automaticamente a linha de comando para ler uma coluna fixa dentro de cada folha.
    Exemplo:
    Tabela:
    AA – Pretendido aceder a =’AA’!$C$10
    AB – Pretendido aceder a =’AB’!$C$10
    AC – Pretendido aceder a =’AC’!$C$10

    O mesmo tenho de fazer com a mesma tabela mas usando CONTAR.SE
    É possível?
    Obrigado desde já.

    • José Augusto says:

      Caro Ângelo Campos

      Supondo que os valores AA, AB, AC estão em ‘OO’!$A$2:$A$10 use:
      =INDIRETO(A2&”!”&”C10″).

      Não entendo o que pretende contar. Quer clarificar a sua pretensão?
      Cumprimentos,
      José Augusto

  16. Ângelo Campos says:

    Elaborei um pequeno ficheiro em Excel para melhor se perceber o que pretendo.
    http://www.lusocarris.com/angelo/Testes-11.xlsx

    • José Augusto says:

      No cometário anteriormente publicado o símbolo diferente não aparece. Assim deve corrigir as fórmulas colocando o símbolo diferente (Menor Maior) entre D3 e “” e entre D11 e “”

  17. José Augusto says:

    Caro Ângelo Campos

    Deve usar na célula Matriz!D2 a seguinte fórmula:

    =SE(OU(A3=”DDDD”;D3″”);INDIRETO(A2&”!$N$4″);””)

    Copie a fórmula até à célula Matriz!D5

    Use na célula Matriz!D10 a seguinte fórmula:

    =SE(OU(A11=”DDDD”;D11″”);SE.ERRO(CONTAR.SE(INDIRETO(A10&”!$H$7:$H$501″);”maçãs”)+CONTAR.SE(INDIRETO(A10&”!$H$7:$H$501″);”pessegos”);”Falta a folha”);””)

    Copie para baixo até à célula Matriz!D13.

    Cumprimentos

  18. Ângelo Campos says:

    Com as suas dicas já completei o trabalho:
    Já aprendi mais um bocadinho de excel.
    Muitíssimo obrigado.

  19. Ângelo Campos says:

    Venho colocar mais um problema.
    tenho o registo da tensão arterial com os seus três valores e depois obtenho um gráfico que fiz de linhas. Acontece que me pediram que quando as medições indicam arritmias aparecesse no gráfico também uma indicação a alertar.
    Terá de ser um gráfico composto, penso eu, mas como coloco o alerta?

Deixe uma resposta

O seu endereço de email não será publicado.

You may use these HTML tags and attributes: <a href="" title="" rel=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

*

Aviso: Todo e qualquer texto publicado na internet através deste sistema não reflete, necessariamente, a opinião deste site ou do(s) seu(s) autor(es). Os comentários publicados através deste sistema são de exclusiva e integral responsabilidade e autoria dos leitores que dele fizerem uso. A administração deste site reserva-se, desde já, no direito de excluir comentários e textos que julgar ofensivos, difamatórios, caluniosos, preconceituosos ou de alguma forma prejudiciais a terceiros. Textos de caráter promocional ou inseridos no sistema sem a devida identificação do seu autor (nome completo e endereço válido de email) também poderão ser excluídos.